Tuesday, July 5, 2011

Sharepoint 2010 e framework 4

Molti di voi probabilmente hanno provato ad utilizzare le novità del framework 4 su Sharepoint 2010 e saranno rimasti delusi quando
hanno scopero che Sharepoint 2010 NON supporta il framework 4 (teniamo presente che Sharepoint 2010 utilizza ASP.NET 3.5 di default).
La motivazione è molto semplice, .NET 4 e ASP.NET utilizzano un CLR diverso (il 4 appunto) rispetto al passato dove, invece, veniva utilizzato il 2:
http://msdn.microsoft.com/en-us/library/bb822049.aspx
Quindi useremo .NET 3.5 finchè non verrà prodotta una nuova versione di Sharepoint Server (che io spero sia rivoluzionata, nel front-end, con l’utilizzo di Razor e MVC)?
La risposta POTREBBE essere no… come leggevo in questo thread: http://social.microsoft.com/Forums/en-US/partnerofficesharepoint/thread/b1dc33b9-2b5b-4a5d-803c-7ab018c4f817

No comments:

Post a Comment